触动精灵 IDE 脚本编辑器使用手册

rourou • 发表于 2018-09-03 19:01:41 • 更新于 2020-09-23 15:16:59 • 0回复

简介

触动精灵脚本编辑器(以下简称编辑器)是触动精灵为广大脚本开发者提供的一个电脑端的集成开发工具,具有脚本编辑、工程管理、函数补全、关键字高亮、函数库高亮、脚本检错、工程打包、远程导入、远程运行、远程调试、日志输出等功能。

注意事项

仅支持连接 iOS 标准版/专业版及安卓标准版,不支持连接其他产品。

安卓标准版需要登录账号并有 VIP 授权,可以在开发者平台的个人中心绑定触动安卓账号,赠送永久 VIP 授权,注意此账号与开发者平台账号不通用,需要在客户端单独注册。

iOS 标准版/专业版需要购买触动授权,可以在触动商城/微信小店:触动精灵/内置购买授权,试用状态无法连接 IDE。

v3.0.0 升级 v3.0.1 及其以上版本后所有工程下的文件将会处于取消关联的状态,请选择工程右键点击全部关联。

第一次使用 3.0 版本 IDE,如果有旧版 IDE 的工程文件,可以点击【文件】 - 【导入工程】选择工程文件夹,将旧版工程导入到新版 IDE 工程列表中,不要 3.0 版本 IDE 的工程目录直接设置为旧版 IDE 工程路径,否者会出现工程下文件取消关联的问题。

v3.0 版本 IDE 新增功能

1.新增导入工程的功能(文件 - 导入工程)

2.新增工程文件取消关联、关联的功能(工程 - 选择文件 - 鼠标右键 -关联/取消关联)

3.新增自动保存代码的功能(文件 - 设置)

4.新增运行脚本自动发送工程文件的功能(文件 - 设置)

5.新增修改工程打包路径的功能(文件 - 设置)

6.新增抓色器截图自动保存路径的功能(文件 - 设置)

7.新增切换 Acess Key 的功能(文件 - 设置)

8.新增函数手册,可以实时查看最新版本开发文档

下载

下载地址:https://www.touchsprite.com/download

注意区分 Windows 版本及 Mac 版本

端口号说明

如果使用的是触动端口号则默认为 50005,模拟器、真机、iOS 设备端口号都为 50005,非模拟器端口号。

如果使用的是积木编程(LuaBox)则端口号为 50007,模拟器、真机、iOS 设备端口号都为 50007,非模拟器端口号,使用节点控制需要先连接到积木编程方能使用。

登录

点击右上角的【登录】按钮 - 输入开发者平台账号、密码 - 选择需要使用的 Acess Key - 点击【确定】,如果没有开发者平台账号、密码请在开发者平台进行注册。

登录后才能连接设备、截图、运行代码。

连接设备

点击【连接设备】按钮会显示和电脑在同一局域网下有客户端授权的设备 IP 列表,双击需要连接的设备 IP 或者选择 IP 点击下方的【连接】按钮都可以连接到设备,点击【刷新】按钮可以刷新设备 IP 列表。

注意:

连接模拟器暂时仅支持开启网桥或者使用蒲公英进行连接,具体使用方法详见此文档中的连接安卓模拟器,使用蒲公英后在IDE的设备日志将无法显示 nLog 返回值暂不支持 ADB 进行连接。

v3.0.1 及其以上版本会自动记录上次输入的 IP。

设置截图方向

在连接设备页面可以设置屏幕方向:竖屏、横屏。

触动精灵 IDE 脚本编辑器使用手册

导入工程

点击【文件】 - 【导入工程】 - 选择需要导入的工程文件夹 - 【确定】,可以将旧版 IDE 工程文件导入到新版工程列表中。

触动精灵 IDE 脚本编辑器使用手册

新建工程

点击【新建工程】 - 输入工程名称 - 【确定】,工程列表中会显示新创建的工程名称。

触动精灵 IDE 脚本编辑器使用手册

导入文件到工程

选择需要添加的工程 - 鼠标右键 - 【导入工程到文件】 - 选择需要添加的文件 - 【打开】,IDE 会按照文件格式将文件自动添加到源码、资源、插件下。

触动精灵 IDE 脚本编辑器使用手册

调用子文件夹下的文件(v3.0.1及其以上版本支持)

1.在工程下手动创建文件夹。

2.将需要调用的文件添加到创建的文件夹下。

3.鼠标右键点击【刷新】。

4.选择添加的文件或者子文件夹 - 鼠标右键点击【全部关联】。

5.将工程发送到设备即可。

具体函数调用方向详见 require 调用子文件夹下文件

关联

选择工程下的文件 -  鼠标右键  - 【关联】/【取消关联】。

选择工程/源码、资源、插件、子文件夹 -  鼠标右键  - 【全部关联】/【全部取消关联】。(v3.0.1 及其以上版本支持)。

取消关联的功能是此文件在工程中不会被删除但是在工程打包及发送工程到设备将被忽略,不进行操作,取消关联后文件名称将增加删除线;如果想恢复为关联状态可以选择取消关联的文件 -  鼠标右键  - 【关联】。

触动精灵 IDE 脚本编辑器使用手册

注意

从 v3.0.0 版本升级到3.0.1及其以上版本后所有工程下的文件会设置为取消关联状态,可以选择工程 - 鼠标右键点击【全部关联】进行关联文件。

截图

连接设备成功后才能进行截图。

点击【截图】会截图当前页面的画面。

点击【取色】按钮会显示取色面板,再次点击【取色】则取色面板会隐藏。

取色快捷键

Ctrl+鼠标左键

取色面板其他按钮对应的功能

触动精灵 IDE 脚本编辑器使用手册

1.点击坐标输入框 - 输入坐标并回车会显示坐标对应的颜色。

2.刷新列表

功能为 打开图片一进行取色,打开图片二点击刷新列表并进行取色,再次再打开图片一,点击刷新列表,图片二取的坐标和颜色值会显示在图片一取色面板的坐标颜色列表中,意思是将多个图上取色的颜色值和坐标合并到一张图的取色面板上。

3.选择范围

点击【选择范围按钮】 - 鼠标左键滑动可以选择查找范围。

点击选择范围按钮下方的输入框可以自定义查找范围。

4.设置找色起始点:左上角、右上角、左下角、右下角。

5.选择代码格式共有六种。

6.设置找色方向。

7.点击【测试】按钮在日志窗口会显示已找到或者未找到。

8.坐标颜色列表,点击【删除】按钮可以删除不需要的颜色及坐标。

连接积木编程

此功能仅支持 v3.0.4 及其以上版本 IDE

  1. 在设备上打开积木编程无障碍开关,积木编程使用方式详见 https://www.touchsprite.com/docs/9099
  2. 设备和电脑需要在同一局域网下。
  3. 连接设备端口号修改为 50007。

打开【积木编程】 - 点击【我的】- 【IP端口】后显示的 IP 即为在 IDE 点击【连接设备】后需要输入的 IP - 将端口号修改为 50007 - 点击【连接】。

触动精灵 IDE 脚本编辑器使用手册

获取控件

连接成功后点击【控制节点】可以获取屏幕控件。

触动精灵 IDE 脚本编辑器使用手册

运行/停止脚本

连接成功后可以在 IDE 编辑代码,控制脚本运行/停止。

触动精灵 IDE 脚本编辑器使用手册

开发文档链接:https://luabox-book.touchsprite.com/

使用文档链接:https://www.touchsprite.com/docs/9099

其他功能

在【文件】 - 【设置】中可以设置以下功能

  1. 是否自动保存代码
  2. 运行脚本时是否自动发送工程文件
  3. 设置工程及打包路径
  4. 截图是否自动保存、设置截图自动保存路径
  5. 设备列表排序方式(设备/IP)(v3.0.1 及其以上版本)
  6. 自定义代码格式(v3.0.1 及其以上版本)
  7. 主题选择(v3.0.1 及其以上版本)

自定义代码参数如下
(X)为取色列表中的 X 坐标
(Y) 为 Y 坐标
(C)为颜色值,此处仅支持十六进制
(D) 为精确度
(SP) 为空格
以下参数仅支持 v3.0.2 及其以上版本
(SX) 为设置的起始点(左上)的 X 坐标(Sx)
(SY) 为设置的起始点(左上)的 Y 坐标
(EX)为设置的终点(右下)的 X 坐标(EX)
(EY)为设置的终点(右下)的 Y 坐标
(CR)为回车 (\r) (CR)
(LF)为换行 (\n)
(T)为制表符 (\t)
(FMC) 为输出 findMultiColorInRegionFuzzy 的前两个参数(此标签仅能用于前缀、中缀、后缀中)(

触动精灵 IDE 脚本编辑器使用手册

在【文件】 - 【更换 Access Key】中可以切换登录账号下的 Access Key。

触动精灵 IDE 脚本编辑器使用手册

触动精灵无法连接 IDE

  1. 检查是否安装的是标准版/专业版同时是否有触动授权,iOS 需要购买触动授权(试用无法连接),安卓需要登录账号有 VIP 授权(无 VIP 授权可以在开发者平台绑定触动安卓账号,此账号与开发者平台账号不通用,需要在客户端重新注册)。
  2. 检查编辑器所在电脑和设备是否在同一 WiFi 网络下(如果未在同一局域网下可以使用蒲公英),是否能 ping 通
  3. 检查设备上的触动精灵服务和广播开关是否为开启状态
  4. 检查电脑上是否开启了 VPN 或其他代理服务,如果是,请关掉并去掉代理
  5. 重启设备上的触动服务和广播开关
  6. 重启路由器

其他常见问题

客户端有授权连接 IDE 显示未授权详见 https://www.touchsprite.com/docs/8906

连接设备列表显示为空(v3.0.1及其以上版本已修复)详见 https://www.touchsprite.com/docs/8910

Mac 电脑无法打开 IDE 详见 https://www.touchsprite.com/docs/8889

退出已登录的开发者账号详见 https://www.touchsprite.com/docs/8837

安装 3.0 版本 IDE 无法安装成功显示安装已终止详见 https://www.touchsprite.com/docs/8881

取色后颜色列表显示为空:需要先点击需要取色的点再使用回车/数字键/Ctrl 加鼠标左键进行取色,需要取色面板左上角图标置灰。

常用快捷键

  • 新建文件

Ctrl+N

  • 打开文件

Ctrl+O

  • 关闭当前文件

Ctrl+W

  • 保存

Ctrl+S

  • 定位到行(仅支持 v3.0.1 及其以上版本)

Ctrl+L

  • 代码折叠(仅支持 v3.0.1 及其以上版本)

Alt+0

  • 代码展开(仅支持 v3.0.1 及其以上版本)

Shift+Alt+0

  • 撤销

Ctrl+Z

  • 重做

Ctrl+Y

  • 查找

Ctrl+F

  • 替换

Ctrl+H

  • 注释

Ctrl+/

  • 代码格式化

Ctrl+J(按照 Lua 原生语法对代码进行格式化处理)

  • 自动缩进(仅支持 v3.0.1 及其以上版本)

Ctrl+I

  • 放大字号(仅支持 v3.0.1 及其以上版本)

CTRL++

  • 恢复原始字号(仅支持 v3.0.1 及其以上版本)

CTRL+0

  • 缩小字号(仅支持 v3.0.1 及其以上版本)

CTRL+-

  • 连接设备

Alt+L

  • 发送文件

Alt+S

  • 远程运行工程

F6

  • 远程运行当前文件

F7

  • 暂停运行

F8

  • 停止运行

F9

  • 编译文件

F10

  • 打包工程

F11

  • 截图

Ctrl+Shift+S

  • 节点控制

Alt+R

  • 打开/关闭取色面板

Ctrl+Shift+R

  • 打开/关闭输出面板

Ctrl+Shift+O

  • 取色面板移动鼠标指针定位 10 个像素(仅支持 v3.0.1 及其以上版本)

Shift + 光标键(↑ ↓ ← →)

  • 取色面板移动鼠标指针定位 100 个像素(仅支持 v3.0.1 及其以上版本)

Ctrl + 光标键(↑ ↓ ← →)

  • 鼠标左键取色

Ctrl+鼠标左键

  • 数字取色快捷键(仅支持 v3.0.1 及其以上版本)

0-9

  • 回车键取色(仅支持 v3.0.1 及其以上版本)

回车键,坐标颜色列表为空时需要使用鼠标左键点击需要取色的点,再点击回车

  • 选取范围(仅支持 v3.0.1 及其以上版本)

Shift+鼠标左键

 

 

v1.2.3 版本 IDE 功能介绍

下载软件

下载地址:http://www.touchsprite.com/tools
IDE 为绿色版本,解压即可,无需安装。

视频教程

常见问题和注意事项

http://v.youku.com/v_show/id_XMTgwNzY3NzAwNA==.html

函数调用堆栈

http://v.youku.com/v_show/id_XMTM0NDQ5MzM1Ng==.html

使用说明

Access Key

首次使用编辑器时,需要输入触动精灵 TS Remote API 的 Access Key,目的是保证编辑器和触动精灵客户端的连接更稳定。
Access Key 可在触动精灵开发者平台获取,注册成功后可在个人中心-> TS Remote API 中查看。

如何修改 key
在编辑器安装路径下找到 key.txt,替换文档中的内容即可。
触动精灵 IDE 脚本编辑器使用手册

软件界面

触动精灵 IDE 脚本编辑器使用手册

视图操作

>在主菜单中的视图菜单中可以对编辑器的一些窗口进行打开/关闭操作,包含 文件管理、工程、设备管理、函数列表、输出窗口等。

  1. 双击任意扩展窗口分页空白处可激活该窗口的移动/拆分功能,可利用此功能自行对各功能窗口进行合理摆放。
  2. 输出、本地控制台、日志输出,这三个窗口仅可以移动位置,不能进行拆分。
  3. 设备管理、函数列表窗口与工程窗口合并时关闭工程窗口将导致三个窗口一起关闭,初次使用请在视图菜单中将工程窗口置于开启状态。

触动精灵 IDE 脚本编辑器使用手册函数视图中会显示当前打开的脚本文件中所有的函数列表

远程设备管理

在快捷视图的设备栏中我们可以对局域网中的远程设备进行管理、这也是文件发送和远程调试运行的必要前提。

  1. 在设备栏中的空白区域点击鼠标右键,在快捷菜单中选择搜索设备,所有在同一局域网中安装过触动精灵 iOS v2.1.7 或 Android v1.1.4 以上版本的设备将会出现在此窗口中。iOS设备以蓝色图标显示,安卓设备以绿色图标显示,如有设备没有正常出现在列表中可多次使用搜索设备功能进行搜索或者选择菜单中的添加设备,手动输入设备 IP 地址进行添加。
  2. 如遇不能添加设备的情况,可以在触动精灵更多界面中检查局域网广播开关是否开启、远程设备与电脑是否在同一个网段、是否打开了多个编辑器窗口导致端口占用、电脑中的防火墙是否关闭、系统中是否安装有虚拟网卡,这些因素都可能会导致添加设备失败。
  3. 通过选中设备栏中已添加的设备,并点击快捷工具栏中的连接设备按钮可建立电脑与移动设备之间的通讯,连接成功后可对此设备进行文件发送、远程运行、远程调试、重启、注销等操作。

远程设备文件管理

在快捷视图设备栏中,双击设备可查看远程设备的 TouchSprite 下的目录结构及文件,右键点击文件,在快捷菜单中选获取文件可将该文件获取到本地目录、点击删除文件可将远程设备上的该文件删除。

  1. 可操作的目录仅限于 TouchSprite\lua TouchSprite\res TouchSprite\log TouchSprite\pluginTouchSprite\config

控制台操作说明

  1. 右键菜单 - 清除输出窗口 清除当前窗口的输出日志
  2. 输出窗口 显示设备连接状态(成功与否)、脚本运行状态
  3. 日志输出 显示脚本运行远程日志(相关函数 nLog)
    触动精灵 IDE 脚本编辑器使用手册

创建工程

创建工程会在工程目录创建一个工程文件夹,里面包含脚本主文件 main.lua、音频图片资源、其他工程文件等。
触动精灵 IDE 脚本编辑器使用手册

注意事项

触动精灵工程默认保存在[TS Studio程序目录]/workspace下,启动程序后自动读取工程显示在左边的工程树中,可以通过文件菜单中设置工程路径改变此默认路径。

  1. 工程中的  main.lua 为脚本主文件,实际执行的脚本将最先加载此文件,不能删除和重命名。
  2. 在工程名上单击鼠标右键,可以对此工程进行的操作。
  3. 在工程中可以添加多个其他文件至工程中,系统将会对导入的文件进行自动分类,可导入工程的文件包含但不限于 *.lua *.luac *.png *.jpg *.bmp *.so *.dylib *.txt,so 库和 dylib 库将直接归入工程中的插件分类,除 lua 及 luac 以外的文件将直接归入工程中的资源分类。
  4. 在工程鼠标右键快捷菜单中可以对整个工程进行压缩打包,将会在你工程路径根目录中生成以工程名为文件名的 zip 包,此压缩包可直接用于上传开发者平台使用。
  5. 在工程鼠标右键快捷菜单中可以将整个工程发送至移动设备,系统将根据工程的分类将其包含的文件自动传送至移动设备对应目录中,需要注意的是,使用此功能需先连接设备。

连接设备

 

  1. 在设备面板中右键,搜索设备或使用 IP 添加设备(设备和电脑需要在同一个 WiFi 下且触动精灵服务开关及触动精灵局域网广播开关已打开)
    触动精灵 IDE 脚本编辑器使用手册
  2. 当扫描不到设备的时候可以尝试通过IP直接添加

触动精灵 IDE 脚本编辑器使用手册

3. 连接到设备,查看输出面板中是否提示设备连接成功
触动精灵 IDE 脚本编辑器使用手册

连接安卓模拟器

注意:安卓需要登录账号并有 VIP 授权才能连接 IDE,可以在开发者平台的个人中心绑定触动安卓账号,赠送永久VIP 授权,此账号与开发者平台账号不通用,需要在客户端重新注册。

第一种方法:

使用蒲公英进行连接,请点击这里查看使用方法,推荐使用第一种方法进行连接。

第二种方法:

  1. 打开已安装了触动精灵安卓版的模拟器,请保证同时只有一个模拟器在运行,如果电脑已连接其他安卓设备请从电脑关闭。
  2. 在模拟器上运行触动精灵 (获取 root 权限) -> 打开服务 -> 打开局域网广播
  3. 下载附件 ADB 模拟器连接 IDE 3.0.zip
  4. 解压缩下载好的压缩文件,运行 连接编辑器.bat 可以连接模拟器
  5. 打开 IDE 的设备-> 右键点击新增设备-> 输入127.0.0.1 ->右键点击连接到设备。
  6. 连接成功后有提示文字,如果要查看 nLog 日志请运行 显示nLog日志.bat

注意事项

模拟器关闭后连接设置将失效,每次重启模拟器后需要重新设置连接。

第三种方法:

以 mumu 模拟器为例(暂时不支持 v2.2.20 以上版本)

  1. 打开网易 mumu 模拟器
  2. 请确保同时只有一个模拟器在运行,如有其他安卓设备请从设备断开
  3. 下载 ADB_模拟器连接
  4. 开始中搜索 cmd
    触动精灵 IDE 脚本编辑器使用手册 5. 打开 cmd 之后输入 cd+adb 所在目录地址后回车
    触动精灵 IDE 脚本编辑器使用手册 6. 执行 adb 命令 adb connect 127.0.0.1:7555 再次回车连接模拟器
    触动精灵 IDE 脚本编辑器使用手册 7. 再次运行连接 .bat 可连接模拟器

常用模拟器端口号

雷电模拟器 5555

夜神模拟器 62001 (暂时不支持 5 系统)

网易 mumu 模拟器 7555 (暂时不支持 v2.2.20 以上版本)

逍遥模拟器 21503

51 模拟器 10001

海马玩 26944(0.8.6)53001 (0.8.5)

蓝叠模拟器 2312

genymtion 5555

如果您是使用以上模拟器其中一个,连接编辑器时需注意端口号是否正确。

第四种方法
雷电/夜神模拟器设置局域网的方法: 打开模拟器后点击设置 ->点击网络设置->开启网络桥连->IP 设置选择 DHCP->安装驱动->点击保存设置->重启模拟器。

触动精灵 IDE 脚本编辑器使用手册 输入雷电模拟器显示的 IP 即可连接 IDE 及抓色器。

USB 连接苹果手机

推荐使用蒲公英进行连接,请点击使用方法进行查看。

首先确保你的手机上已经安装了触动精灵 iOS 客户端,然后下载附件中的文件,按照教程进行设置即可。
附件下载 iOS 的触动 USB 端口监听.zip

使用方法:

将 iOS 设备用数据线与电脑连接,并确保电脑上已经安装 iTunes(可下载 iTools,只要能识别到手机即可)

  1. 解压附件,运行其中的 开始USB监听.bat 文件
  2. 如果窗口中出现 [INFO]Device connected:设备号 字样,代表监听成功。注意图中显示的设备号为 UDID,并不是触动精灵的设备号。
  3. 触动精灵 IDE 脚本编辑器使用手册
  4. 打开 IDE,在设备面板中输入 127.0.0.1 添加设备
  5. 触动精灵 IDE 脚本编辑器使用手册
  6. 右键选择连接设备,在输出面板中看到连接成功的提示就成功了
    触动精灵 IDE 脚本编辑器使用手册

注意事项
如果运行监听文件一闪而过或者一直失败,请按照教程中的方法修改注册表。

连接设备报错

  1. 检查是否购买了触动授权,iOS 需要购买触动授权,安卓需要登录账号购买 VIP(此账号与开发者平台账号不通用需要在客户端单独注册)。
  2. 检查编辑器输入的 Access Key 是否正确(登录开发者平台在个人中心-> Access Key 中查看)
  3. 检查编辑器所在电脑和设备是否在同一 WiFi 网络下,是否能 ping 通
  4. 检查设备上的触动精灵服务和广播开关是否为开启状态
  5. 检查电脑上是否开启了 VPN 或其他代理服务,如果是,请关掉并去掉代理
  6. 重启设备上的触动服务和广播开关
  7. 重启路由器
  8. 删掉编辑器,从压缩包中重新解压到桌面或系统盘根目录

远程调试

  1. 在工程面板中右键 发送工程到设备,会将当前工程文件夹下的脚本和资源文件都发送到设备触动精灵 IDE 脚本编辑器使用手册
  2. 打开脚本主文件,点击菜单栏中的 开始/继续远程运行该文件(Alt + R)
    触动精灵 IDE 脚本编辑器使用手册
  3. 脚本中的 nLog 输出在左下方日志输出面板中

触动精灵 IDE 脚本编辑器使用手册

连接 IDE 显示连接成功但是显示 code:L 400 错误

如果连接 IDE 显示以下错误触动精灵 IDE 脚本编辑器使用手册 请检查 iOS 设备是否购买触动授权,安卓设备是否登录账号并且购买了VIP。
IDE 和抓色器需要有授权才能连接,
iOS 可以在客户端内置购买或者在触动商城购买授权,试用状态无法连接IDE。
安卓可以在开发者平台的个人中心中绑定触动安卓账号,赠送永久 VIP 授权(此账号与开发者平台账号不通用,需要在客户端重新注册)。

如果购买授权后仍提示这个报错,请删除 IDE 安装目录下的 tsok 文件,重启下 IDE 及触动服务,重新连接试下。

nLog 不输出日志

  1. 打开电脑任务管理器,在进程中找到 lua.exe,关闭后再次运行脚本尝试
  2. 关闭电脑的防火墙再次尝试
  3. 如果开启了虚拟网卡,关闭后再次尝试

编辑器左侧栏不显示中文函数

在中文函数前面加任意英文字母即可。

触动精灵 IDE 脚本编辑器使用手册

工程打包

在工程视图中选中要打包的工程,在右键菜单中选择工程打包,会在工程文件夹同级目录下生成一个 zip 包。
工程文件夹下的脚本和资源文件都会包含在 zip 包中。
触动精灵 IDE 脚本编辑器使用手册触动精灵 IDE 脚本编辑器使用手册

一个包含脚本文件、扩展库文件和资源文件的工程

打包失败

如果遇到无论如何都打包不成功的情况,可备份工程文件、删除编辑器、重新解压再尝试。

注意事项

很多人使用绿色三角按钮的调试功能会提示需要触动精灵授权,在此提示,不建议大家使用这个功能,请使用后面带电脑标志的调试(需要先连接设备)。

  1. 如果设备和编辑器连接不成功,请尝试开关触动精灵服务、重启编辑器、重启路由,但是最重要的是,确保你的手机和电脑在同一个无线网下。
  2. 如果本地打开了 VPN 或其他代理工具,请关闭后再使用编辑器的脚本调试功能。
  3. 触动精灵 iOS 脚本路径为 /var/mobile/Media/TouchSprite/lua
  4. 触动精灵 Android 脚本路径为 /sdcard/TouchSprite/lua

自定义界面

打开编辑 - 首选项 - 用户配置 即可即时调整配色方案

自定义配色方案

打开编辑器目录下 cfg\tomorrow.lua 编辑 custom 表里的具体对应颜色,保存后在编辑 - 首选项 - 用户配置 选择 custom 方案即可

触动精灵 IDE 脚本编辑器使用手册

当前版本提供的配色方案:

Tomorrow
TomorrowContrast
TomorrowNight
TomorrowNightEighties
TomorrowNightBlue
TomorrowNightBright
Zenburn
Monokai
TouchSprite
Molokai
SolarizedDark
SolarizedLight
NotepadPlusPlus
SciTeLuaIDE

触动精灵 IDE 脚本编辑器使用手册

改变字体

打开触动精灵编辑器的配置文件 \cfg\user.lua,找到下面的文字(约 24 行)

  1. editor.fontname = "Courier New"

触动精灵 IDE 脚本编辑器使用手册 将 "Courier New" 改成电脑系统已有的字体
例如改成

  1. editor.fontname = "Arial"

保存后,重启编辑器就可以了

触动精灵脚本格式

二进制脚本 - TSP

  1. TSP 为触动精灵独有脚本格式,仅能被触动精灵识别,此格式由触动精灵开发者平台生成。
  2. 将你的脚本工程打包为 zip 格式,并上传至开发者平台,即可生成 TSP 格式的脚本。
  3. TSP 脚本为一个单独文件,里面包含了你的所有脚本文件,图片、音频、文本等资源及一些脚本基本信息。
  4. TSP 格式为加密格式,需联网验证,无法查看和修改脚本的源代码。
  5. TSP 运行时将会释放里面包含的资源文件,需要注意的是,在触动精灵iOS v2.2.0 以上版本中,图片资源每次运行都会释放至 /User/Media/TouchSprite/res/ 目录,如目录中存在同名文件,将进行覆盖操作。

明文格式脚本 - lua

  1. 明文脚本一般以 lua 为扩展名,为文本格式,可以用任意文本编辑器打开编辑。
  2. 触动精灵中录制所产生的脚本即为明文脚本。
  3. 可将明文脚本文件在编辑器中打开进行编辑,并打包上传至开发者平台生成加密的二进制脚本。

常用快捷键

  • 调试运行 F6
    本地代码运行,不支持运行包含触动精灵扩展函数的代码
  • Alt + S
    发送文件到设备,需先在左侧项目列表中选中需要发送的文件(支持 CTRL 多选),发送文件格式支持 lua、luac、txt,使用此功能前需要先连接设备
  • Alt + R
    将当前脚本传至设备上并运行,使用此功能远程运行脚本不会出现运行提示框,此功能需先连接设备
  • F7
    对当前代码进行二进制编译,生成的文件路径会在输出窗口提示
  • Shift + F7
    代码检查,可检查是否有语法错误,可在输出栏直接双击错误提示跳转到对应行
  • F9
    在当前光标行设置断点,在远程调试中使用
  • F10
    单步运行跟踪,在远程调试中使用
  • Ctrl + Shift + D
    开始/继续 远程调试,在远程调试中使用
  • Shift + F5
    终止远程调试中的脚本运行
  • Ctrl + Shift + W
    打开/关闭 监视窗口,用于远程调试
  • Ctrl + Shift + S
    打开/关闭 调用堆栈窗口,用于远程调试

脚本编辑

  • Ctrl + Shift + p

打开/关闭 文件管理窗口

  • F12
    对整个代码进行折叠,再按一次取消折叠
  • Ctrl + I
    一键自动缩进,可对当前代码进行智能缩进排版
  • Ctrl + D
    快速复制当前行,以当前光标为准
  • Ctrl + C
    快速复制当前行到剪贴板
  • Ctrl + V
    黏贴剪贴板内容到光标位置
  • Ctrl + U
    代码注释,对已经注释的代码使用会取消注释
  • Ctrl + B
    打开快捷操作栏,可用来快速检索内容,如:直接输入字符可直接在整个项目目录搜索对应内容打开并显示在当前窗口
  • Ctrl + G
    可通过输入行号快速跳转到指定行
  • Ctrl + F2
    对光标所在行设置标签,用于不同行之间的快速跳转
  • F2
    跳转至下一个标签行,需先设置标签
  • Shift + F2
    跳转到上一个标签行,需先设置标签
  • Ctrl + F
    搜索替换
  • Ctrl + F
    在当前代码中搜索
  • Ctrl + Shift + F
    在文件中进行搜索、支持多级子目录、支持搜索结果上下文显示,在搜索结果中双击可自动打开对应文件并跳转至对应行
  • Ctrl + "+"
    对显示字体进行放大
  • Ctrl + "-"
    对显示字体进行缩小
  • Ctrl + 0
    还原字体大小为默认

附录

触动精灵脚本开发指南

新手必读,最全面的脚本开发必备常识、视频教程、开发工具:https://www.touchsprite.com/docs/4945

已知与触动精灵冲突的插件列表

showUI 不能弹出、点击没反应、滑动失效等问题有可能是由于安装了冲突插件引起的
https://www.touchsprite.com/docs/536

21 人觉得有帮助 有帮助